When Apache2 won't reload, restart, stop or start, with errors like:
- "Apache2 is not running"
- "There are processes named 'apache2' running which do not match your pid file which are left untouched in the name of safety, Please review the situation by hand."
- "(98)Address already in use: AH00072: make_sock: could not bind to address [::]:80"
- "no listening sockets available, shutting down"
- "The apache2 instance did not start within 20 seconds. Please read the log files to discover problems"
Find the processus id of Apache2 with:
>pidof apache2
Kill the process(es):
>sudo kill -9 <pid>
Then you can start Apache2 as usually:
>sudo service apache2 start
If sudo kill -9 <pid> doesn't work, just try:
>sudo kill <pid>
Comments