ubuntu@osboxes:~$ sudo apt upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages will be upgraded: libmysqlclient21 mysql-client mysql-client-8.0 mysql-client-core-8.0 mysql-server mysql-server-8.0 mysql-server-core-8.0 7 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. Need to get 24.1 MB of archives. After this operation, 1,196 kB of additional disk space will be used. Do you want to continue? [Y/n] Get:1 http://es.archive.ubuntu.com/ubuntu focal-updates/main amd64 mysql-client-core-8.0 amd64 8.0.21-0ubuntu0.20.04.3 [4,207 kB] Get:2 http://es.archive.ubuntu.com/ubuntu focal-updates/main amd64 mysql-client-8.0 amd64 8.0.21-0ubuntu0.20.04.3 [22.0 kB] Get:3 http://es.archive.ubuntu.com/ubuntu focal-updates/main amd64 mysql-server-8.0 amd64 8.0.21-0ubuntu0.20.04.3 [1,249 kB] Get:4 http://es.archive.ubuntu.com/ubuntu focal-updates/main amd64 mysql-server-core-8.0 amd64 8.0.21-0ubuntu0.20.04.3 [17.4 MB] Get:5 http://es.archive.ubuntu.com/ubuntu focal-updates/main amd64 libmysqlclient21 amd64 8.0.21-0ubuntu0.20.04.3 [1,222 kB] Get:6 http://es.archive.ubuntu.com/ubuntu focal-updates/main amd64 mysql-client all 8.0.21-0ubuntu0.20.04.3 [9,420 B] Get:7 http://es.archive.ubuntu.com/ubuntu focal-updates/main amd64 mysql-server all 8.0.21-0ubuntu0.20.04.3 [9,548 B] Fetched 24.1 MB in 2s (12.4 MB/s) Preconfiguring packages ... (Reading database ... 234559 files and directories currently installed.) Preparing to unpack .../0-mysql-client-core-8.0_8.0.21-0ubuntu0.20.04.3_amd64.deb ... Unpacking mysql-client-core-8.0 (8.0.21-0ubuntu0.20.04.3) over (8.0.20-0ubuntu0.20.04.1) ... Preparing to unpack .../1-mysql-client-8.0_8.0.21-0ubuntu0.20.04.3_amd64.deb ... Unpacking mysql-client-8.0 (8.0.21-0ubuntu0.20.04.3) over (8.0.20-0ubuntu0.20.04.1) ... Preparing to unpack .../2-mysql-server-8.0_8.0.21-0ubuntu0.20.04.3_amd64.deb ... Unpacking mysql-server-8.0 (8.0.21-0ubuntu0.20.04.3) over (8.0.20-0ubuntu0.20.04.1) ... Preparing to unpack .../3-mysql-server-core-8.0_8.0.21-0ubuntu0.20.04.3_amd64.deb ... Unpacking mysql-server-core-8.0 (8.0.21-0ubuntu0.20.04.3) over (8.0.20-0ubuntu0.20.04.1) ... Preparing to unpack .../4-libmysqlclient21_8.0.21-0ubuntu0.20.04.3_amd64.deb ... Unpacking libmysqlclient21:amd64 (8.0.21-0ubuntu0.20.04.3) over (8.0.20-0ubuntu0.20.04.1) ... Preparing to unpack .../5-mysql-client_8.0.21-0ubuntu0.20.04.3_all.deb ... Unpacking mysql-client (8.0.21-0ubuntu0.20.04.3) over (8.0.20-0ubuntu0.20.04.1) ... Preparing to unpack .../6-mysql-server_8.0.21-0ubuntu0.20.04.3_all.deb ... Unpacking mysql-server (8.0.21-0ubuntu0.20.04.3) over (8.0.20-0ubuntu0.20.04.1) ... Setting up mysql-client-core-8.0 (8.0.21-0ubuntu0.20.04.3) ... Setting up libmysqlclient21:amd64 (8.0.21-0ubuntu0.20.04.3) ... Setting up mysql-server-core-8.0 (8.0.21-0ubuntu0.20.04.3) ... Setting up mysql-client-8.0 (8.0.21-0ubuntu0.20.04.3) ... Setting up mysql-server-8.0 (8.0.21-0ubuntu0.20.04.3) ... mysqld will log errors to /var/log/mysql/error.log 2020-07-29T11:06:04.239031Z 0 [ERROR] [MY-010946] [Server] Failed to start mysqld daemon. Check mysqld error log. Warning: Unable to start the server. Job for mysql.service failed because the control process exited with error code. See "systemctl status mysql.service" and "journalctl -xe" for details. invoke-rc.d: initscript mysql, action "start" failed. ● mysql.service - MySQL Community Server Loaded: loaded (/lib/systemd/system/mysql.service; enabled; vendor preset: enabled) Active: activating (auto-restart) (Result: exit-code) since Wed 2020-07-29 11:06:43 UTC; 6ms ago Process: 9047 ExecStartPre=/usr/share/mysql/mysql-systemd-start pre (code=exited, status=0/SUCCESS) Process: 9070 ExecStart=/usr/sbin/mysqld (code=exited, status=1/FAILURE) Main PID: 9070 (code=exited, status=1/FAILURE) Status: "Server startup in progress" dpkg: error processing package mysql-server-8.0 (--configure): installed mysql-server-8.0 package post-installation script subprocess returned error exit status 1 Setting up mysql-client (8.0.21-0ubuntu0.20.04.3) ... dpkg: dependency problems prevent configuration of mysql-server: mysql-server depends on mysql-server-8.0; however: Package mysql-server-8.0 is not configured yet. dpkg: error processing package mysql-server (--configure): dependency problems - leaving unconfigured No apport report written because the error message indicates its a followup error from a previous failure. Processing triggers for systemd (245.4-4ubuntu3.2) ... Processing triggers for man-db (2.9.1-1) ... Processing triggers for libc-bin (2.31-0ubuntu9) ... Errors were encountered while processing: mysql-server-8.0 mysql-server E: Sub-process /usr/bin/dpkg returned an error code (1)